Changes in several names in the AMUSE code-base
We have removed the concept of "state" and "normal" attributes. The difference between "state" and "normal" attributes was never completely worked out.
Originally a code could have "state" attributes that captured the minimal state of the particles or gridpoints of a code. For example a gravitational dynamics code will have "position", "mass" and "velocity" for the state attributes, but the particles can also have "acceleration", "radius" or "potential". In practice we never made good use of this facility and it only made the code hard to read.
Most of this removal is internal to the AMUSE code and should not impact users. The most public change is in the method copy_values_of_state_attributes_to. This method is now called copy_values_of_all_attributes_to. For all scripts in subversion we have updated the code.
evolve and evolve_model
We renamed evolve to evolve_model. The evolve method was defined on most low-level code interfaces. And evolve_model was used in all high-level code. This made it harder to remember the right method to call. We changed all the evolve methods on the low-level interfaces to match the name used in the high-level interfaces. As most scripts will use the high-level interface this should not impact most existing scripts.
- sse: evolve was renamed to evolve_star
- bse: evolve was renamed to evolve_binary
If you're scripts should fail to work after an svn update please send an e-mail to the amuse mailinglist.